OVHcloud Network Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance

[GLOBAL][Backbone] - Network incident notification

Incident Report for Network & Infrastructure

Update

We have new information regarding the incident that affected your service(s).

Please find below an update on the situation:
Update : The incident on our Backbone has been fixed since 20/05/2026 15:15 UTC.
However, the BYOIP orders are temporarily held in a queue and will be treated as soon as possible.
Ongoing Actions : The incident has been identified and corrected. It is being closely monitored to ensure long-term stability.

We will keep you updated on the progress and resolution.

We apologize for any inconvenience caused and appreciate your understanding.
Posted May 20, 2026 - 17:45 UTC

Monitoring

Service has been fully restored since 20/05/2026 15:15 UTC. Monitoring remains active to ensure long-term stability.

Here are some supplementary details :

Start time : 20/05/2026 14:38 UTC
Impacted Service(s) : Some of our services were temporarily unavailable.
Customers Impact : Some customers were temporarily facing issues to connect and use our services.

We apologize for any inconvenience caused and appreciate your understanding.
Posted May 20, 2026 - 15:27 UTC
This incident affects: Infrastructure || Backbone.