Get webhook notifications whenever Network & Infrastructure creates an incident, updates an incident, resolves an incident or changes a component status.
We are pleased to inform you that the incident affecting our Network offering has been resolved.
Start time : 12/05/2026 13:00 UTC End time : 12/05/2026 13:47 UTC Root Cause : This incident was caused by a network equipment issue.
We apologize for any inconvenience caused and appreciate your understanding.
Posted May 12, 2026 - 13:58 UTC
Update
We are pleased to inform you that the incident affecting our Network offering has been resolved.
Start time : 12/05/2026 13:00 UTC End time : 12/05/2026 13:47 UTC Root Cause : This incident was caused by a network equipment issue.
We apologize for any inconvenience caused and appreciate your understanding.
Posted May 12, 2026 - 13:57 UTC
Investigating
We are currently experiencing an incident affecting our Network offering, which is causing temporary latencies in Madrid. Please find the details: Start time : 12/05/2026 13:00 UTC Service impact : Customer may impact production traffic. Some destinations may experience increased latency or become inaccessible. Root cause : Network equipment issue. Ongoing actions : Our teams are actively working to resolve the incident and restore services as quickly as possible. We will keep you informed of developments and the resolution of the incident.
We apologize for the inconvenience and thank you for your understanding.
Posted May 12, 2026 - 13:16 UTC
This incident affected: Infrastructure || Backbone.