Get webhook notifications whenever Network & Infrastructure creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2023 - 15:59 UTC
Scheduled
Start time : 27/11/2023 14:00 UTC End time : 27/11/2023 17:00 UTC Service impact : None Service improvement : Our teams need to clean an air duct to correct an air flow error.
Posted Nov 27, 2023 - 15:55 UTC
This scheduled maintenance affected: Infrastructure || BHS (BHS6).