Get webhook notifications whenever Network & Infrastructure creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2023 - 12:01 UTC
Scheduled
Start time : 22/03/2023 12:00 UTC End time : 22/03/2023 20:00 UTC Service impact : None Service improvement : Our teams will perform a scalable maintenance operation on our high voltage electrical distribution equipment.
Posted Mar 21, 2023 - 20:36 UTC
This scheduled maintenance affected: Infrastructure || BHS (BHS1, BHS2, BHS7).